博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
Starship Troopers
阅读量:5249 次
发布时间:2019-06-14

本文共 3517 字,大约阅读时间需要 11 分钟。

Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.
To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.
A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 
Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.
The last test case is followed by two -1's.
 
Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 
Sample Input
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 
Sample Output
50 7
题意:n个点代表n个房间。每个房间对应bug和val值。给定士兵数m。每20个bug需要一个士兵。一直房间的相连情况。求最大值
题解:n个点构成一个森林。构造一个树。树形dp
dp[i][j]=max(dp[i][j],dp[i][j-k]+dp[child[i]][k])//i代表房子j代表士兵

#include<stdio.h>

#include<string.h>

#include<iostream>

using namespace std;

int n,m;

int dp[105][105];

int pic[105][105];

int visit[105];

int d[105];

struct lmx{

       int bugs;

       int val;

};

lmx lm[105];

int ma(int a,int b)

{

       return a>b?a:b;

}

void dfs(int s)

{

       int i,j,k;

       visit[s]=1;

    int num=(lm[s].bugs+19)/20;

       for(i=num;i<=m;i++)  dp[s][i]=lm[s].val;

    for(i=1;i<=d[s];i++)

       {

           int u=pic[s][i];

           if(visit[u]) continue;

                     dfs(u);

              for(j=m;j>=num;j--)

              {

                     for(k=1;k+j<=m;k++)

                     {

                            if(dp[u][k])

                            {

                                   dp[s][j+k]=ma(dp[s][j+k],dp[s][j]+dp[u][k]);

                            }

                     }

              }

       }

}

int main()

{

       int i,j,a,b;

    while(cin>>n>>m)

       {

              if(n==-1&&m==-1) break;

              for(i=1;i<=n;i++) scanf("%d%d",&lm[i].bugs,&lm[i].val);

        memset(d,0,sizeof(d));

              memset(dp,0,sizeof(dp));

              memset(visit,0,sizeof(visit));

              for(i=1;i<n;i++)

              {

                     scanf("%d%d",&a,&b);

                     d[a]++;

                     pic[a][d[a]]=b;

                     d[b]++;

                     pic[b][d[b]]=a;

              }

              if(m==0) puts("0");

              else

        {

              dfs(1);

              printf("%d\n",dp[1][m]);

              }

       }

       return 0;

}

转载于:https://www.cnblogs.com/ffhuguang/p/3219439.html

你可能感兴趣的文章
高并发抢购思路
查看>>
【转】Linux下添加新硬盘,分区及挂载
查看>>
NI labview2014/2015/2016的超快速入门教程之使用VI模板(培训一)
查看>>
python 学习路程(一)
查看>>
sqlParameter<数据库>
查看>>
认识 AbstractMap!
查看>>
Python魔术方法
查看>>
Hibernate非主键关联
查看>>
各城市地形图的分幅与编号查询系统
查看>>
【摘】设计模式入门指南
查看>>
数据方舟 for Excel工具箱使用说明
查看>>
Python 网络爬虫 002 (入门) 爬取一个网站之前,要了解的知识
查看>>
django 获取当前访问的URL
查看>>
javascript的闭包
查看>>
vs2003与vs2010的取屏幕高度的异同和人数判定的限制
查看>>
NOI Linux的安装说明以及使用指南
查看>>
判断当前日期是否在[startDate, endDate]区间
查看>>
SQL SERVER赋权限
查看>>
VIO第三讲_LM曲线拟合实验
查看>>
java-分支语句
查看>>